HOME / COMMUNITY Switch to knowledge base

Clients not receiving emails with invoice


#1

Hi

Not quite sure why, but since yesterday, when I send an invoice to my customer’s listed email address, it never seems to come through. I always CC myself on invoices and that email does come through.

I have a ‘test’ client setup, which has an email address associated that I have access to and I have just tried sending a test invoice to that account / email address and it hasn’t come through (though CC copy has been delivered to me on a different address).

QuickFile log does show that invoice has been emailed and I’ve not had any Delivery Failure Notifications or error messages from QuickFile system, so I am a bit stumped as to why it seems not to be working. Any ideas?

Thanks

Ed Squires


#2

Hi @edsquires

Is the email sent log is showing as ‘Sent’ (and not ‘Blocked’ or ‘Failed’), then as far as we can tell, it’s been delivered.

Are you using your own SMTP server? If you are, it may be worth asking your email provider to see if anything has flagged up on their end.

I will however send you a private message and see if anything is showing on our system that hasn’t fed through yet. Please look for a green notification in the top right hand corner shortly.


#3

Hi. I have had the same problem. Apparently sent invoices have not been received even though several have got through previously to the same customer. Last time they had an invoice it was March.


#4

It shows on all invoices as sent, not blocked or failed.


#5

When you think that it is all working nicely somebody’s security update will throw a spanner in the works.

When invoices are overdue I look to see if they have been opened and, if not, send an email from my own mailbox.

As well as the issues of SMTP against sending from Quickfile the amount of fake invoice spam in circulation means that the problem could be with the recipients’ own filters. It is difficult to send out an invoice without using trigger words such as “invoice” or “order”.


#6

Hi @Solartears

As @FolkLondon mentions, email can be a bit of a minefield when it comes to trying to resolve these issues.

There’s a few things to consider, depending on your set up:

  • If you’re using your own SMTP server, QuickFile is unable to track bounces (which means if an email is returned for whatever reason, we are unable to show this)
  • We do however try our best to check when an email is opened, but this can vary depending on your client’s set up. Not all of them will trigger this, and some will even trigger it automatically.
  • If you’re using QuickFile’s default mail setup (which is via Amazon using the mail@quickfile.co.uk address), Amazon will track bounces for us and report back
  • If an email does bounce, depending on the bounce, a block may be put in place for a period of time. If an issue does crop up, this will be shown on the client record

You can view the blocks, fails and sends on the Email Sent Log (I believe you’ve already found this, but in case you haven’t it’s found by going to Account Settings >> All Settings >> Email Sent Log. This feature does require a power user subscription.

To check an individual email address, if you view the client, this is shown beneath their record, as highlighted in email complaints & bounces article.

I hope that helps, but if you’re still stuck, please send me a private message with the email address in question and I’ll take a closer look for you.


#8

I used the forum and knowledgebase to diagnose why invoices had stopped being received by a customer who had previously received them via quickfile. I have been copying and pasting invoices and sending them from my email account. I understand that the problem is, in all likelihood, a spam filter preventing my invoices being allowed into recipient inboxes. They show as unread on my dashboard. Is there anything that quickfile can do to put this right? I was advised to contact the quickfile technician who answered the topic on the forum, but I don’t know how to send that person an email.


#9

Hi @Solartears

Email delivery is a bit of a gamble in some cases, but we try our best to deliver these as reliably as possible. For instance, we use Amazon to send all our emails and run them through tests. But, even something as simple as the subject or the wrong word in the email can be detected as spam.

There are 2 types of spam reactions too. Firstly, the email may be rejected entirely, meaning it will be returned to us with this message. Secondly, it may be delivered but to a spam box rather than the inbox. In the second case, we don’t be notified.

If you have a Power User Subscription, if you go to Account Settings >> All Settings >> Email Sent Log, you can view all emails sent from your account, with a status message (e.g. “Sent”). If this doesn’t say sent, it could suggest an issue.

It’s also worth checking the client record itself, as we list if there are any blocks enforced or errors there:

If everything in your QuickFile account checks out all OK, then everything that can be done by QuickFile, has been done. But there are a few more options, including using your own SMTP server. But using this option will remove the bounce checker as we have no way of monitoring that.

I hope this helps.


#10

Thank you. I did try changing the subject as this was mentioned as a potential trigger on the forum. I will check the client records themselves too, so far the emails show as sent but not read, if they say they have not got them in their inbox. I will use regular email if I can’t sort it. Thank you so much for your reply.


#12

Is this every client or a subset?
I know that BT have been stepping up their own filtering to be very agressive which has created problems for my own mailing list but I haven’t checked if it has spilled over into Quickfile invoice emails.


#13

Hi All

So it would seem I’ve not been the only person to encounter issues with sending mail via my ‘own’ SMTP server, which in comforting, in an odd kind of way.

My suggestion would be to approach the provider of your SMTP server… if you can be bear to read on, here’s what I found:

Contrary to my original thought, my issue was not resolved by removing and re-authenticating the SMTP server. This worked for one email, but after that, the original issue reoccurred.

It seemed odd to me, as the same SMTP server accepted and delivered my invoice emails (which were a forwarded CC copy of the email I’d received from QuickFile’s AWS mail server). For whatever reason, the SMTP host wasn’t delivering emails sent from QuickFile. There were no error messages and as far as the QuickFile system was concerned, the messages were being delivered. My tests didn’t concur, so I decided to approach the host for the SMTP server - Easyspace (IOMartMail), in my case.

Having logged a support ticket with Easyspace, they eventually agreed to track a test email sent from QuickFile through their system. They found that the email was being blocked as Spam. I couldn’t understand why, as when I sent that very same email via my Outlook client, it did get through, despite using the exact same authentication details in Outlook, as used in QuickFile and having the same content.

Easyspace were able to release my test email from their filter and the message was then delivered. Asking Easyspace why the email was blocked, they indicated that the message scored highly on the spam filter scale, as it had “Invoice” in the subject and a URL link in the body of the email. I asked if the message was being blocked due to it being sent from QuickFile - I was looking for a reason why Outlook worked, by QF didn’t - I was advised it was just the subject and URL, which I still seems strange to me. They did indicate that there had recently been a large number of spam messages picked up that had similar traits to my messages, which was likely why it had scored highly on their filter system.

Easyspace suggested that I stop using “Invoice” in the subject and remove the URL. This rather annoyed me, tbh. As their paying customer, I shouldn’t be dictated to as to what I can put in my legitimate business related emails. However, as a test, I did try removing “invoice” from the subject, but it still got blocked.

I approached Easyspace again and explained that since the email was to send an invoice and the URL was a link to that invoice, I couldn’t avoid including those elements. They then indicated that the issue could be resolved by removing my domain name from routing through the Spam filter. However, they warned me that if my domain was reported for Spam, it would automatically get blocked, without investigation and it would be up to me to get them to remove it. Frankly, I couldn’t see any difference to the situation I had already, so I agreed. I send marketing email via MailChimp, so I didn’t see that it would be an issue.

Easyspace made the change and a hour or so later, confirmed the completion of the process. When I sent a new test invoice, I was pleased to find that it did get through. I have since sent invoice emails to various customers and haven’t seen an issue.

I’d like to say I completely understand why this issue occurred… particularly why the same email content was only blocked when sent from QuickFile. Sadly, I can’t, but I am pleased it’s working again, as it was a proper pain in the backside having to send them out manually!

Good luck to all having the same or similar issues - I hope you find the answer for your setup. :smile:


#14

Thanks for sharing that, it may prove useful to others encountering similar issues.

One particular tool we’ve used in the past is Mail Tester, it’s free for limited usage and it will give you a nice summary of potential issues.

You could set the supplied email address as a test client and send an invoice to the address. Then send another that has been routed through Outlook. Would be interesting to see the results.


#15

This topic was automatically closed after 5 days. New replies are no longer allowed.