HOME / COMMUNITY Switch to knowledge base

Not letting me fill in VAT return

Hi I am trying to do VAT return (my first one with this company) and it says “you are not yet authorised to view this report for the VRN 319699744 . Please ensure your VAT number is correct and you have connected the corresponding HMRC Tax Account. If you have recently enrolled on the MTD scheme please allow 24 hours for HMRC systems to update”. I did previously fill in the VAT return but it was rejected as I had the wrong dates. Now I can’t even fill in a form as it says the above. I have connected to HMRC I believe.

Hi @Joelle,

Can you confirm that you’ve signed up with HMRC for MTD and had the confirmation email from them?

Hi Beth

I think I have. I did go through it again last week but didn’t get an email to confirm. Do you know exactly what I have to do. I have done it with two other businesses successfully so not sure if things have changed in the past few months.
All the bets
Joelle

hi @Joelle,

There is a guide on how to enrol with MTD here: Signing up for Making Tax Digital

Then once you have completed the enrolment there is a guide on making sure your settings are correct within quickfil here: HMRC Tax Accounts - MTD Returns

Have a go at working your way through those and this may resolve the issue.

Another way to check if you have successfully signed up to MTD is to log into your HMRC account, it should state on there (Rather than giving you the option to enrol).

Hope this helps

If you have separate government gateway accounts for the different businesses, are you sure you’ve definitely connected the correct one for this QuickFile account? The key word in the error message is “corresponding”. Try disconnecting, then making sure you’re completely logged out of tax.service.gov.uk before you go through the connect procedure again.

Thank you so much for taking the time to help - I have just done it but don’t remember doing the same for my other 2.

This topic was automatically closed after 7 days. New replies are no longer allowed.