HOME / COMMUNITY Switch to knowledge base

SMTP Setup with cPanel

Hi Ive been trying to setup my email account with the smtp my email provider has given to me however it’s not working. My email provider has asked what the IP address of the software that is sending out the mail so they can add to server firewall, as well as check their logs.

Hi @ImraanR

Who is your email provider?

Unfortunately due to the nature of the setup, we’re not able to give a specific IP address, but we will work with you to get this working.

Hi Matthew

I use a company called YP Solutions, they use C-panel for web and email hosting.

That shouldn’t be a problem - I’m aware of quite a few users with cPanel setups using their own SMTP.

I’m not able to find the SMTP details, but if you have them, secure connections are the better ones (for obvious reasons).

When you try setting this up, do you see any errors on the SMTP settings page in QuickFile?

Hi Matthew

These are the error messages:

smtp port 25
|It looks like there was a problem reaching your SMTP service|
|Error Message|Mailbox unavailable. The server response was: Access denied - Invalid HELO name (See RFC2821 4.1.1.1)|

smtp port 26
It looks like there was a problem reaching your SMTP service
Error Message Mailbox unavailable. The server response was: Access denied - Invalid HELO name (See RFC2821 4.1.1.1)

smtp port 587
starttls selected
It looks like there was a problem reaching your SMTP service
Error Message The operation has timed out.
More Details Your SMTP server did not reply in a timely fashion. Please ensure the port number is correct and any firewall on the SMTP server is allowing outside access.

smtp port 465
starttls selected
It looks like there was a problem reaching your SMTP service
Error Message Failure sending mail.
More Details Unable to connect to the remote server

For what its worth, I’ve recently set up the SMTP and it worked first time for me. My email also runs via a host using cPanel.

From what I can see, the settings are exactly the same as if you were setting up an email app on you Mac, PC or phone. You’re just adding the sending details, not the receiving. So whatever settings you have in a working email app, Outlook, Apple Mail, whichever, are the ones to use. Are you using the settings from a known working email account? I want QF to send invoices as if they came from my main email address so that works fine. But if you want them to come from another address, that email account will need to be set up using cPanel, tested and working first.

1 Like

Hi, I want to use my own email. The smtp settings are the outgoing same as what I have in my email client (ms outlook)

If the settings you’ve put on QuickFile are the same as you use elsewhere, but they still aren’t working, it does suggest an issue on your email providers end.

The only thing to bear in mind that does catch some people out, is “StartSSL” is a secure connection (where available).

A few other people have posted about cPanel connections too, so they may be worth a look:

Hi ImraanR,
I use use cPanel as well. My settings:
Port 25
email address: Your email address
From Name: Must be the same as on your cPanel/host provider account
Host name: That is where I had problems because I can NOT use my website address. It sounds weird but your host provider hires cPanel and gives you access to the part the hired from cPanel. So, your provider hired cPanel with their details. That means for the host name you may have to use the details from your provider. May your situation is different but that was and is the fact in my case.
User name: email address (in my case)
Password: your password (look out case sensitive)
Use secure connection: Tick

When testing your connection you must use a different email address.

I hope it helps a bit

2 Likes

Hi Mathew
This the response I’ve have from my email hosting support…

Not sure what it could be as from server side everything is working fine, we have users using Quickbooks, Xero, etc doing the same thing and as long as SMTP details are used correctly it works fine. I myself have the same on a 3rd party CRM as well as Kashflow accounting software and both work fine. It definitely seems like something to do with the 3rd party application. As mentioned if we can get an IP address then we can check server logs for errors that can help find the problem.

@ImraanR - are you using the same details that you use on outlook or your phone?

I use a cpanel host and not having any issues. It’s worked great for a few years now.

Spike, I am using the same setting as what I have configured in office outlook.
Thanks…

The IP address shouldn’t be an issue. If you imagine when using email on your phone (through a 4G/5G network), then the IP address will be changing all the time as these aren’t static.

As I mentioned above, we’re not able to provide you with the IP addresses, but can advise you that QuickFile uses a well-known cloud infrastructure provider to handle this.

From what I can see, YP Solutions uses eUK Host as their provider for hosting, who themselves have posted several options in regards to ports etc. to be using.

If the settings are exactly the same as what you’re using in Outlook, then it would suggest that your hosting provider is blocking us or rejecting the connection, which only they can resolve unfortunately. But we have a good number of users using cPanel hosts with their SMTP setup on QuickFile, so cPanel nor QuickFile itself isn’t the issue.

If your host is blocking us or rejecting it, then they should be seeing logs of this and be able to rectify it.

1 Like

Finally got it working.
Host name only required the domain name with out smtp or mail in front of it.

Eg
Host name : mydomain.com
Port : 587
Starttls : ticked

All working now, thanks for your help.

Strange, if it works on all your other devices it should still work on Quickfile.

Depends on the precise details of the certificates and how well or otherwise the TLS library on the QuickFile end supports SANs and SNI.

Possibly. I was going on the error further up which seemed to suggest it didn’t even respond with an error. I hate email anyway!

Glad to hear you managed to get this resolved @ImraanR!

This topic was automatically closed after 2 days. New replies are no longer allowed.